Rear Hatch light

How-to's and repair secrets for your 4WD can be found here. Have a question? Ask it in here!
Post Reply
User avatar
Buzzard67
Advanced Member
Posts: 65
Joined: Tue Jul 17, 2012 10:00 am
My tercel:: 1984 Toyota Tercel Delux
Location: Minnesota

Rear Hatch light

Post by Buzzard67 » Sat Jul 13, 2019 4:46 pm

I just replace my dash lights with Green LEDs and knocked out my dome light and hatch backlight. Turns out was just a blown fuse. Replaced the fuse and dash and dome lights work again but the hatch light quit working. Replaced the bulb and made sure I place it left to right then right to left. Still didn't work. Bought another brand new light and replaced the new bulb with another still not working.
Any thoughts?

It will bug me until I fix it.

I will send pictures of the dash lights and product number and package I used.
Truth be told I got all the dash info from member DCN to check out his thread for all the instructions to get all wire plugs and a tricky blind reach for the speedo cable. Great information could not have done it without his instruction.
Member DCN Instruction: "it is fairly simple to access the instrument cluster, just a few minutes with a Phillips screwdriver. As I recall, you unscrew the hood over the cluster, two screws on each lower corner, two above the face on the underside of the hood. You also have to pull the little knobs off (do not lose them!). and pull a couple of electrical connectors (push on the little tab to release the connectors). Then the cluster itself is easy to remove with four screws, then you pop off the speed do cable (you have to reach your hand behind it and depress the plastic clip on the end of the cable) and then you unplug several connectors.
inclinometer and heater control panel is even easier, just some screws that allow you to remove the panel and expose the lights. I really only takes about ten min to get it apart and back together once you locate all the screws."

there might be a thread on this topic somewhere in the archives, with pictures if I remember correctly.

good luck
thumbnail_20190713_221118.jpg
thumbnail_20190713_221104.jpg
thumbnail_20190713_221243.jpg
You do not have the required permissions to view the files attached to this post.
Last edited by Buzzard67 on Sun Jul 14, 2019 9:35 am, edited 3 times in total.

User avatar
BaileySims
Highest Ranking Member
Posts: 556
Joined: Sat Aug 30, 2014 6:52 pm
My tercel:: 1983 Tercel SR5 4WD
Location: Texas
Contact:

Re: Rear Hatch light

Post by BaileySims » Sat Jul 13, 2019 4:52 pm

Something on the other side of the housing is messed up, at least this was the case for me. I can't remember a whole lot, but I took it apart and soldered some wires to some bad connections and have some half ass led light strips on there.

If need be, I can take it out again and look around and post pictures.
WAGON MAFIA.
Blood, sweat and beers.

User avatar
Buzzard67
Advanced Member
Posts: 65
Joined: Tue Jul 17, 2012 10:00 am
My tercel:: 1984 Toyota Tercel Delux
Location: Minnesota

Re: Rear Hatch light

Post by Buzzard67 » Sun Jul 14, 2019 9:27 am

BaileySims wrote:
Sat Jul 13, 2019 4:52 pm
Something on the other side of the housing is messed up, at least this was the case for me. I can't remember a whole lot, but I took it apart and soldered some wires to some bad connections and have some half-ass led light strips on there.

If need be, I can take it out again and look around and post pictures.
Any Help would be great.
I did just replace the heater / cold dash panel and all the cables could there be a harness or wire in there I moved disconnected? Just so additional information.

Post Reply