Oil pressure dropping?

How-to's and repair secrets for your 4WD can be found here. Have a question? Ask it in here!
Post Reply
SirFoxx
Member
Posts: 41
Joined: Sun Feb 05, 2017 5:42 pm
My tercel:: 1988 DLX Tercel Wagon w/ weber

Oil pressure dropping?

Post by SirFoxx » Fri Sep 01, 2017 8:08 pm

Hello--

It seems like I can never get a break with my '88 wagon. A few days ago, the motor started slinging oil everywhere under the hood. I thought it was the front main seal, so I set off on replacing that. When it came down to the front cover, I asked my friend if he knew how it came off. He told me that itll slide off once all the bolts are undone, and that you may have to pry on it just a bit to break it free of the RTV. So I did that, and got it move about 1/4" away from the block before I stopped. I went in and looked up how to take it off, and lo behold, the pickup tube is bolted onto it.

Today--I drove to an auto parts store to get a valve cover gasket, and on the way home (~12 miles, 20 minutes), the oil light started flickering on around 800rpm, then 1000, then 1100....until I got home, and at that point, it wouldnt turn off until about 2000rpm. I don't think I am going to drive it any more, but what could be causing the oil pressure to drop like this? I replaced the rod bearings when I refreshed the motor, so I don't think its those. I have a feeling I bent the pickup, but that wouldn't explain why the oil pressure is continually dropping off.

User avatar
Mark
Highest Ranking Member
Posts: 742
Joined: Mon Apr 22, 2013 9:49 pm
My tercel:: 1984 Automatic, 1981 sedan
Location: Victoria, B.C.

Re: Oil pressure dropping?

Post by Mark » Fri Sep 01, 2017 10:22 pm

Assuming the oil level isn't actually too low and the pump is loosing suction, I'd have a look at the oil pressure sensor (sender) itself. It can spray oil out pretty good when it fails (this happened to me) and it also might account for the low oil pressure warning light.

SirFoxx
Member
Posts: 41
Joined: Sun Feb 05, 2017 5:42 pm
My tercel:: 1988 DLX Tercel Wagon w/ weber

Re: Oil pressure dropping?

Post by SirFoxx » Sat Sep 02, 2017 1:37 pm

Just replaced the sensor. Still have the same issue. I'm thinking it's the bypass valve in the front cover. I'm still trying to decide if I want to fix it or get a 4a. It's half off this weekend and the pick n pulls, I may go pull a 4a bottom end and refresh it.

Post Reply